CI: Debian uses noninteractive frontend

parent d6e77b6e
......@@ -148,7 +148,7 @@ build:debian:
<<: *distro_debian
extends: .template:build
before_script:
- apt-get update && apt-get install -y build-essential cmake ninja-build python3 libxml2-dev libtclap-dev libreadline-dev qtbase5-dev graphviz-dev libjsoncpp-dev
- apt-get update && DEBIAN_FRONTEND=noninteractive apt-get install -y build-essential cmake ninja-build python3 libxml2-dev libtclap-dev libreadline-dev qtbase5-dev graphviz-dev libjsoncpp-dev
test:debian:
<<: *distro_debian
......@@ -156,7 +156,7 @@ test:debian:
dependencies:
- build:debian
before_script:
- apt-get update && apt-get install -y build-essential bash cmake libxml2 libreadline8 libqt5widgets5 libqt5xml5 graphviz libjsoncpp1
- apt-get update && DEBIAN_FRONTEND=noninteractive apt-get install -y build-essential bash cmake libxml2 libreadline8 libqt5widgets5 libqt5xml5 graphviz libjsoncpp1
# -----------------------------------------------------------------------------
......@@ -180,7 +180,7 @@ build:ubuntu:lts:
<<: *distro_ubuntu-lts
extends: .template:build
before_script:
- apt-get update && apt-get install -y build-essential cmake ninja-build python3 libxml2-dev libtclap-dev libreadline-dev qtbase5-dev graphviz-dev libjsoncpp-dev
- apt-get update && DEBIAN_FRONTEND=noninteractive apt-get install -y build-essential cmake ninja-build python3 libxml2-dev libtclap-dev libreadline-dev qtbase5-dev graphviz-dev libjsoncpp-dev
test:ubuntu:lts:
<<: *distro_ubuntu-lts
......@@ -188,7 +188,7 @@ test:ubuntu:lts:
dependencies:
- build:ubuntu:lts
before_script:
- apt-get update && apt-get install -y build-essential bash cmake libxml2 libreadline7 libqt5widgets5 libqt5xml5 graphviz libjsoncpp1
- apt-get update && DEBIAN_FRONTEND=noninteractive apt-get install -y build-essential bash cmake libxml2 libreadline7 libqt5widgets5 libqt5xml5 graphviz libjsoncpp1
# -----------------------------------------------------------------------------
......@@ -196,13 +196,13 @@ build:ubuntu:rolling:
<<: *distro_ubuntu-rolling
extends: .template:build
before_script:
- apt-get update && apt-get install -y build-essential cmake ninja-build python3 libxml2-dev libtclap-dev libreadline-dev qtbase5-dev graphviz-dev libjsoncpp-dev
- apt-get update && DEBIAN_FRONTEND=noninteractive apt-get install -y build-essential cmake ninja-build python3 libxml2-dev libtclap-dev libreadline-dev qtbase5-dev graphviz-dev libjsoncpp-dev
test:ubuntu:rolling:
<<: *distro_ubuntu-rolling
extends: .template:test
before_script:
- apt-get update && apt-get install -y build-essential bash cmake libxml2 libreadline8 libqt5widgets5 libqt5xml5 graphviz libjsoncpp1
- apt-get update && DEBIAN_FRONTEND=noninteractive apt-get install -y build-essential bash cmake libxml2 libreadline8 libqt5widgets5 libqt5xml5 graphviz libjsoncpp1
dependencies:
- build:ubuntu:rolling
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment